スレッドの評価:
  • 回答数:0 平均:0
  • 1
  • 2
  • 3
  • 4
  • 5
DesktopStationのRailComDisplay
#1
レンツLRC120と同じ機能を有する、DesktopStationのRailComDisplayについて、話しましょう!

wiki:
https://desktopstation.net/wiki/doku.php/railcomdisplay

頒布ページ:
https://desktopstation.net/shop/products/detail/77
返信
#2
昨日RailComDisplay+DSair2にて、LoksoundV5 micro DCC(モーター、サウンド制御)+ワンコイン6x2個(ヘッド、テール用)編成でテストしてみました。特に支障なく順調に車両アドレス表示していたのですが、一度だけ突然列車の速度が急減(約半減)その後30秒程度で勝手に復旧しました。現象が起こった時、ヘッド、テールライト、サウンドには特に異変はありませんでした。現象再現しないので、とりあえずご報告まで。
返信
#3
報告ありがとうございます。

考えられるとすれば、ショートか、それに相当する現象が起きて、瞬間的な電圧降下となったということも考えられます。
RailComDisplayにある1.8Ωの抵抗が、大電流発生時は電圧降下を発生させやすくなっています。
返信
#4
RailCom対応のコントローラに関して:
DSmainR5.1(Core) 及び D99 HACX のRailCom対応ファームウェアが公開されていたので、
書き換えて RailCom Display を動かしてみました。使用した車両は、LokSound V4.0 を搭
載したものです。

DSmainR5.1 及び D99 HACX ともに、車両番号は問題なく表示されましたが、ただ、
D99 HACX は、運転方向の切換えボタンを押しても、運転方向をForward側に切換えでき
ず、Reverse側に固定されたままになってしまいました。

RailCom 非対応の前バージョン20200308版のファームウェアに戻すと、Forward/Reverse
切換えができるので、RailCom対応版の20210130版 と RailCom 非対応の前バージョン
20200308版 で、運転方向切換えに関連しそうな箇所をざっと見比べてみたところ、
RailCom対応版の20210130版 では、
DSCoreM.h のヘッダファイルで、
    #define  GO_FWD  0x01
    #define  GO_REV   0x02
と定義されていたので、20200308版 と同じように、
    #define  GO_FWD  0x00
    #define  GO_REV   0x01
に変更して動かしてみたところ Forward/Reverse 切換えができ、車両番号の表示も問題
ありませんでした。多分、この箇所の変更のみで良さそうに思いますが、もし、他の部分
に影響が出そうであれば教示ください。
返信
#5
こんにちは
手持ちのdsmain5.1 のmcoreを書き換え当方もrailcom display が正常に動いていますが?正常に書き込めたのかどうか不安ですwバージョン番号が読み取れませんw確認の方法がありますか?

desktopstation0.98がdsmainで立ち上がってきません。0.97は問題ないのですが、、
返信
#6
Desktop Station Software の件、0.97d を使用していましたが、0.98 をダウンロードして使ってみよう
とDesktopSation.exe をクリックしましたが、確かに Desktop Station Software は立ち上がりませんね。
理由はよくわかりません?が、0.98版 は英文版でのバグ修正とあり、また、0.97d で RailCom Display
等も問題なく利用できているため、0.97d をそのまま使っていこうと思っています。
返信
#7
HACXについては後日修正させていただきます。
DesktopStationSoftware 0.98で動かない件は調査します。

ちなみに、DSwebapp winでも動かないでしょうか?
https://desktopstation.net/blog/2021/02/...%e7%99%ba/
返信
#8
DSwebapp_win の件、コマンドステーションは "DSmain R5.1" を使い動作確認を行ってみました。

DesktopStation WebApp for Windows の画面が立ち上がり、ポート選択、通信開始、Server address
クリックで運転操作のweb画面たち上がったので、以下の動作確認をしてみました。

 ・Loco の運転/停止、正/逆運転
 ・F0~F3 までのFunction
 ・ポイントの切換え
 ・RailCom Display でのLoco番号表示
 
に関しては、一通り問題なく動いているようですが、ただし、

 ・CD read (CV1,CV8,CV28,CV29 をreadしてみた)

に関しては、読み取り中 Loco は微動していましたが、結果の CV値が表示されませんでした(CV値 0 のまま)。

上記以外の PWM analog運転、線路レイアウト、CV programing の Simple Control、Education platform、
Web Sound機能 は確認しておらず大まかな確認となりましたが。

追記:webブラウザは、chrome を使っていますが、八つある設定画面の内、Setting screen画面で "Wifi Config"
の下の部分が "Etc" の部分と重なってしまい、見難い状態になってしまっていました。
返信
#9
ありがとうございます。
開発環境はまったく同じなので、何かDesktopStationSoftware 0.89の方が変になってるようです。

動作確認もありがとうございます。
DSwebapp winは、まだ実装していない機能(CVの受け渡しなど)もあるので、原因はそこかと思います。
返信
#10
「Desktop Station Air」”https://desktopstation.net/wiki/doku.php/dsair_jp”(旧DSAir)へファーム「DSairFirmware_r3.1」を書き込みましたが問題なく動作し、「RailComDisplay」のアドレス表示機能も確認できました。
返信


ページジャンプ:


このスレッドを閲覧中のユーザ: ゲスト: 1